Support Article
Mashup does not always appear on host application screen
SA-51663
Summary
Sometimes the mashup script is not loading correctly and therefore Pega returns an empty page.
Tracing doesn't show any results and the Pega application doesn't log any activity. There are not any records in any logs about this error.
Error Messages
Not applicable
Steps to Reproduce
- Login on one portal which is using the mashup gadget.
- Go to a second portal which is also using a mashup gadget.
Root Cause
A defect or configuration issue in the operating environment.
It is found that mashup gadget were pointing to the same server, expect for the port.
For instance:
First mashup: http://xyz:1000/prweb
Second mashup: http://xyz:2000/prweb
Because of this, the same cookies (JsessionID or Pega-Rules) is being sent to both server which result in the Pega server getting unclear about the session.
This happens because browser enforce same origin policy for cookies based on hostname/path but not port.
In other words, about cookies, from the browser perspective, http://xyz:1000/prweb and http://xyz:2000/prweb are the same server so same cookies must be sent.
Resolution
From the browser perspective, the URL of both application must be different to avoid confusion related to cookies.
There are numerous solution to this such as hosting one of the application on a different server, or using virtual host and so on.
Published May 3, 2018 - Updated October 8, 2020
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