Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Mobile log in fails with error when worklist is empty

SA-56022

Summary



Mobile log in fails with error when worklist is empty.


Error Messages



ERROR|JS: clientstorehelper.open() 'ASSIGN-' '*' failed
ERROR|JS: clientstorehelper.open() getAllAssignments failed



Steps to Reproduce

Log in to the mobile application and ensure that there are no items in the worklist.


Root Cause

A defect in Pegasystems’ code or rules. The assignments were loaded by selecting all the items by 'ASSIGN-' category instead of by loading the worklist page.


Resolution

Apply HFix-43318. This changes the console.error to a warning in this scenario and ensures the exception handler does not stop the processing while encountering this particular use case.



Published April 27, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us