Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Modal Flows fail to execute

SA-71252

Summary



When launching a modal flow from a Navigation rule, an error occurs and the modal flow fails to execute.


Error Messages



Failed to find a 'RULE-OBJ-FLOW' with the name <flow_rule_name> that applies to '@baseclass'. There were 2 rules with this name in the rulebase, but none matched this request. The 2 rules named <flow_rule_name> defined in the rulebase are: 2 related to applies-to class '@baseclass', but were defined on subclasses: <work_class_name>.


Steps to Reproduce

  1. Create a table layout in a section to display the work object details in each row.
  2. Add an icon to launch a menu in the section that corresponds to display the work object details.
  3. On click of one of the menu options, launch a modal window to display other details of the work object.
  4. Configure a flow to display the modal window.
  5. Include a utility as the first step to call an activity which opens the work object.
  6. Run the flow and launch the modal window.


Root Cause



An issue in the custom application code or rules. The context page was not created before the modal window was opened.


Resolution



Perform the following local-change: 
  1. Run the activity first on click of the menu option.
  2. Use the step page in the Using Page.
  3. Open the modal window.

 

Suggest Edit

Published February 20, 2019 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us