Support Article
Multiple PEGA0026 and PEGA0011 errors occur in logs
SA-10495
Summary
User is getting PEGA0026 and PEGA0011 errors while triggering webservice.
Error Messages
In the alert logs user see PEGA26 and PEGA11 errors.
Steps to Reproduce
Trigger webservice through load runner or do a load testing through Soap UI.
Root Cause
The root cause of this problem is in a third-party product. CPU virtualisation is set run at 500 Mhz, hence overall system performance is bad.
Resolution
The performance situation is solved.The explanation for this behavior is as follows:
Pega ran a non-Pega benchmark test (just a simple java program which timed itself doing a CPU-intensive operation) and this showes that the system is running around 7 times slower than the old system.
This effectively ruled out Pega as well as DB, network, application server and so on as being the root cause of the issue.
Further investigation found that a setting in the virtualisation layer had restricted the CPUs to run at 500MHz, when they were supposed to be running at 3.6GHz.
This has now been rectified and as a result, the Pega0011 times have fallen down to around 1-2 seconds. This is about the expected times and Pega recommends raising the alert threshold to further reduce the number of these appearing in the logs as the performance is seen as acceptable.
Published July 2, 2015 - Updated October 8, 2020
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