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Support Article

MXClientException: Exception getting MBean Server connection

SA-47478

Summary



After adding nodes to the System Management Application (SMA), the SMA does not load the nodes. This occurs after a server restart.


Error Messages



com.pega.jmx.ui.util.JMXClientException: Exception getting MBean Server connection. User failed to be authenticated.


Steps to Reproduce



Add a node to the SMA.


Root Cause



A defect or configuration issue in the operating environment. All SMA related information is stored in the Nodes.xml file. The file is created in the temp directory of the Application server. When the server is restarted and the temp directory deleted, the Nodes.xml file is also deleted. Hence, the SMA does not load the nodes.


Resolution



Perform the following local-change:
  1. Change the path of the Nodes.xml file to a different location other than temp.
  2. Add the below setting to the JVM arguments in WebLogic.

    -Dcom.pega.sma.tmpdir=<path_for_Nodes.xml>
  3. Delete nodes in the SMA.
  4. Add the above setting to the Application server.
  5. Restart the server.

Published March 26, 2018 - Updated October 8, 2020

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