Support Article
No result found when searching for a case ID in Pega 8.1.3
SA-82365
Summary
Unable to search for the work items that are created after performing a re-index.
Error Messages
com.pega.dsm.dnode.api.StreamServiceException: Unable to start Kafka broker. Last state was: NotConnected
Error: Exception thrown by the agent : java.rmi.server.ExportException: Port already in use: 9999; nested exception is:
java.net.BindException: Address already in use (Bind failed)
Steps to Reproduce
- Create a case work object in the Case Manager portal.
- Search the case ID created. No results are found.
- Perform a re-index. The case ID can be searched.
Root Cause
FTSIncrementalIndexer QueueProcessor did not run because the Stream Service failed to join the cluster.
Resolution
Perform the following local-change:
1. Create a Dynamic System Setting (DSS) with the below options:
- Owning Ruleset - Pega-Engine
- Setting Purpose - prconfig/dsm/services/stream/pyJmxPort/default
- Value - Port number. For example, 1111
In <port_number>, provide the available port number.
2. Restart the server.
Published August 15, 2019 - Updated December 2, 2021
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