Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Not able trace agent activity from SMA after 7.2.2 upgrade

SA-38093

Summary



Not able to trace agent activity from System Management Application (SMA) after their application upgraded to Pega 7.2.2.

They are able to see Out-of-the-box (OOTB) rules but not customized agent activity.


Error Messages



Not Applicable


Steps to Reproduce



1. Create an agent and activity
2.Try to trace from SMA after delay. In tracer user cannot see agent activity.


Root Cause



A defect in Pegasystems’ code or rules. User has changed the behavior to always take the ruleset list from the remote requestor in Pega 7.2.2.

Resolution



Apply HFix-33935.

Installation Instructions:

1. After installing the HFix, server restart is required.
2. From Designer Studio, go to System > Operations > Agent Management.
3. In the Agent name column, search Agent using filter.
4. Expand the agent and select the node.



5. On top right, click on Trace > Trace now.

NOTE: This hotfix works for tracing the custom rules from all the rulesets only from Designer Studio. This will not work tracing rules in SMA.

Published June 1, 2017 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice