Support Article
Notification when AES Agents are disabled
Summary
Users do not see anything in Autonomic Event Services (AES) for their application. Turns out that PegaAES ruleset agents for the AES application itself were down. Request is to get email notification when PegaAES agents are disabled.
Error Messages
Not Applicable
Steps to Reproduce
Not Applicable
Root Cause
Incomplete product documentation: Documentation does not explain how AES environments should be set up to get notification when AES Agents are disabled. BUG-263168 has been raised for this.
Resolution
Here’s the explanation for the reported behavior:
AES provides an email subscription for Agent Disabled Scorecard. To get emails when AES Agents are disabled, set up another AES instance that monitors the PROD AES.
This configuration requires a secondary QA or Staging AES instance to be configured to monitor the Production AES, as well as the QA or Staging PRPC instance.
For example:
There are three AES instances in Production: AES1, AES2, and AES3. AES1 is for monitoring all Production apps. AES2 and AES3 are for monitoring QA apps.
Either AES2 or AES3 can be configured to monitor the AES1 instance and send notification if the agent is disabled.
Published August 23, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.