Support Article
Null Pointer Exception when finalizing a revision
SA-47042
Summary
Null Pointer Exception when a Revision Manager finalizes a revision.
A Revision Manager (RM) creates a revision and passes it to the Strategy Designer (SD). A SD returns the assigned work to the RM as expected. However, in this case, the RM is unable to cannot finalize the revision because graphical user interface (GUI) returns a Null Pointer Exception.
Error Messages
Exception on Pega Marketing GUI:
Flow: pzPackageRevision
Step: (Utility1)
Error: java.lang.NullPointerException
Exception in PegaRULES log;
[fault (self-tuning)'] [TABTHREAD2] [ ] [ RULESET:01.01.01] ( internal.util.MoveLog) INFO IP_ADDRESS |HOST_NAME ABC_RevisionManager - Operation Status: Constructing export file -- please wait.....
[fault (self-tuning)'] [TABTHREAD2] [ ] [ RULESET:01.01.01] ( internal.util.MoveLog) INFO IP_ADDRESS |HOST_NAME ABC_RevisionManager - Operation Status: Constructing export file -- please wait......
[fault (self-tuning)'] [TABTHREAD2] [ ] [ RULESET:01.01.01] ( internal.mgmt.Executable) ERROR IP_ADDRESS |HOST_NAME ABC_RevisionManager - Exception
java.lang.NullPointerException
at com.pegarules.generated.activity.ra_action_newruleset_d8511ee867afcae530c4c98a901bdba3.step13_circum0(ra_action_newruleset_d8511ee867afcae530c4c98a901bdba3.java:1197)
at com.pegarules.generated.activity.ra_action_newruleset_d8511ee867afcae530c4c98a901bdba3.perform(ra_action_newruleset_d8511ee867afcae530c4c98a901bdba3.java:302)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3553)
at com.pega.pegarules.session.internal.mgmt.Executable.invokeActivity(Executable.java:10711)
at com.pegarules.generated.activity.ra_action_pycreaterevisionbranch_00959628155806ff6e56eb543baecec5.step6_circum0
Steps to Reproduce
- Create a revision
- Create a Change Request (CR)
- Submit the CR and the revision
Root Cause
A defect or configuration issue in the operating environment.
The overlay and the revisions used for packaging were corrupted. This could occurs because of an incorrect email account configuration which results in email failures.
This issue can also occur when a revision or CR case is corrupted after an upgrade and updates occur in the case or flow in the new release.
Resolution
Perform the following local-change:
- Clean up the faulty revision by running the below out-of-the-box activities by providing the pzinskeys:
RevisionManagement-Work-Revision.pyRemoveRevision
RevisionManagement-Work-ChangeSet.pyRemoveCR - Recreate the overlay and the revisions subsequently
Published May 23, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.