Support Article
OOTB Transfer functionality does not work correctly
SA-61445
Summary
The out-of-the-box Transfer functionality does not work correctly in Pega Platform 7.2.1.
Error Messages
Not Applicable
Steps to Reproduce
- Log in as an operator (for example: cmax).
- Launch the Interaction portal.
- Navigate to New Phone call > User. Enter Last name as 'Max'.
- Click Search and select the first contact.
- Navigate to Add Task > Service Request > Add task(s).
- Click Local Action > Transfer > Select Operator (User1).
- Click Submit.
- Log in as User1 operator and click My Cases.
- Search for a case number and open it.
- Double click the Address record which has a particular State (for example, EOLA) in the Address field. Instead of moving to the second stage (that is, CreateRequestStageScreenFlow) in the case, the flow is redirected to the Confirmation screen with the Confirm button. When the User1 clicks the Confirm button, the case is reassigned back to the owner (that is, cmax)
Root Cause
This behavior is as per Pega product design.
Resolution
Here's the explanation for the reported behavior:
The CreateRequestStageScreenFlow Start shape is configured such that it is routed to the owner. Hence, the flow is routed to the Owner of the Case while reaching this screen flow.
Published September 6, 2019 - Updated October 8, 2020
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