Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Operator Default Locale does not work in Mashup

SA-81866

Summary



Pega Web Mashup is created and embedded in to a third-party website. The Mashup is configured to login automatically using the below attribute:

data-pega-action-param-parameters= '{"UserIdentifier" : "MashupUser","Password": "cnVsZXMxMjMk","Encode":"Enable",pzUsePreferenceSkin:"always", pzSkinName:"CSFW_MASHUP"}'

The operator (MashupUser) has a default locale of 'iw'. On logging in with the user and using the Interaction portal, the system renders in the Right-to-Left (RTL) layout. However, in the Pega Web Mashup, the system renders in the Left-to-Right (LTR) layout.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create Pega Web Mashup and embed it in a third-party website.
  2. Configure the Mashup to automatically log in using the below attribute:

    data-pega-action-param-parameters= '{"UserIdentifier" : "MashupUser","Password": "cnVsZXMxMjMk","Encode":"Enable",pzUsePreferenceSkin:"always", pzSkinName:"CSFW_MASHUP"}


Root Cause



A user profile setting caused the issue.


Resolution



Perform the following local-change:
  1. Navigate to Pega Dev Studio > User Profile > Localization section.
  2. Uncheck the 'Ignore locale' option.
Suggest Edit

Published December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us