Support Article
Outbound campaign failed due to VBD issue
Summary
One of the outbound campaigns (PRC) fails while it is processing the offer flow.
ERROR MESSAGES)
02:19:38,223 INFO [stdout] (Dispatcher-Thread-94) Caused by: org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [http://a5prdap02.xyz.com:8080/vbd/service/vbdService]; nested exception is java.net.SocketTimeoutException: Read timed out
02:19:38,223 INFO [stdout] (Dispatcher-Thread-94) at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.convertHttpInvokerAccessException(HttpInvokerClientInterceptor.java:216)
Steps to Reproduce
Run an outbound campaign.
Root Cause
A defect in Pegasystems’ code or rules:
Time out errors when accessing Visual Business Director (VBD) and campaign failures.
Resolution
Perform the following local-change:
Set the VBD eviction timeout to 50 days.
INSERT INTO <your VBD schema>.PR_DATA_VBD_CONFIG (PZKEY, PZVALUE) VALUES ('vbd.datasource.eviction.timeout', '4320000');
Tags:
Published April 30, 2018 - Updated December 2, 2021
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