Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

OverallSLA assignment is not completed when work object resolved

SA-15662

Summary



The work object is resolved but the OverallSLA assignment does not complete. The assignment remains in the pc_assign_workbasket table.


Error Messages



Not Applicable.


Steps to Reproduce

  1. Create a work object with an overall SLA (service level agreement).
  2. Resolve the work object.


Root Cause



An issue in the custom application code or rules. The activity used to resolve the work object, sets the status to Resolved-Completed using a Property-Set but the Status-Resolved ticket was not set. 

Resolution



Perform the following local-change:

Call the UpdateStatus activity instead of using the Property-Set step to set the status to Resolved-Completed. 
The UpdateStatus activity calls the Resolve activity, which sets the Status-Resolved ticket used to end the OverallSLA flow.

 

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us