Support Article
Passed Deadline value through Property Set
Summary
Developer is trying to set the deadline value through a property set, as mentioned in the below PDN article. However, it is not working as expected.
https://pdn.pega.com/how-set-service-level-agreement-sla-late-event-property-reference
Error Messages
No error message.
Steps to Reproduce
1) Create an SLA rule and appy it in on WorkObject (WO ).
2) Configure an activity to set the late time as mentioned in the PDN article: https://pdn.pega.com/how-set-service-level-agreement-sla-late-event-property-reference
3) Let the SLA pass its deadline.
4) Observe that late event not getting fired.
Root Cause
Trying to set the value of pxLateTime on the assignment page.
Resolution
It is not possible to set the value of pxLateTime on the assignment page of overallSLA flow.
According to the deadline escalation activity(setLateTime), user is trying to define the value of pxLateTime on the newAssignPage to a dynamic value.
Since the SLA that is involved here is overallSLA, which runs the SLA on the whole WO, it is not possible to set the pxLateTime on the assignment page related to this flow.
This (Overall SLA and its assign page) is something internal to Pega and the properties on this page cannot be modified by an external activity.
Process is specific to assignment SLA:
https://pdn.pega.com/how-set-service-level-agreement-sla-late-event-property-reference
Published May 19, 2016 - Updated October 8, 2020
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