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Support Article

Passivized Data not clearing up

SA-3160

Summary



Passivized data not getting cleared up, which is indeed causing the Pega Temp Directory size to increase. If we don't monitor this regularly, we are having occurences of disk size getting filled and system getting crashed.

HFIX-7608 (Batch Requestors count growing in Number) is not installed (but neither does it appear in the CATALOG file).

SystemCleaner is running on all nodes.

What value is the PersistRequestor dynamic system setting set to?

- onTimeOut

Please confirm that your dynamic system setting for PersistRequestor/storage is set to (or defaults to) "filesystem".

- We have checked in DSS and prConfig.xml file, however, this is value is not present in any of them. PRPC should therefore use the default which is the “filesystem”


Error Messages



N/A.


Steps to Reproduce



N/A.


Root Cause



The logic within the deleteExpiredThreads() and deleteExpiredRequestors() API currently does not accommodate this condition (where you have pages persisted for requestors that have not been persisted), so these pages will continue to exist and will not be purged by SystemCleaner.


Resolution



This issue is resolved by hotfix item Hfix-10301

Published January 31, 2016 - Updated October 8, 2020

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