Support Article
Pega CTI-Interaction not starting automatically
SA-32226
Summary
User has requirement to start the interaction automatically if call comes from CTI (IVR)
For this, user had updated the call treatment rule. User selected Automatically and started the interaction.
User is calling from the other extension, here call alerting service is hitting, mapping the data up to call interaction page.
But call is not delivering and interaction not launching. When user look in the CTI logs, user has observed the "Ready","alerting","ConnectionEstablished","Disconnected" events.
User has the following questions:
1) How to launch the interaction automatically
2) How to establish the call or deliver the call
3) List the all the CTI events and their descriptions.
Error Messages
Not Applicable
Steps to Reproduce
Not Applicable
Root Cause
User had created application specific portals which were not part of the circumstance definition rule:
CPMPortalType • CPMInteractionPortal
Resolution
Add application specific portals to the rule: CPMPORTALTYPE!CPMINTERACTIONPORTAL circumstance rule.
Published January 25, 2017 - Updated December 2, 2021
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