Support Article
Pega CTI logs created in two filesystem locations
SA-52508
Summary
Two different versions of CTI logs are created on the system. One log created in the Pega log file directory contains less information, while the other created in the server default location contains detailed CTI and debug information.
The version in the Pega directory is a result of the prlogging.xml configuration, while the other is based on the CTILINK engine configuration in the system.
Error Messages
Not Applicable
Steps to Reproduce
- Update the CTI log file location in the prlogging.xml configuration file.
- Restart the CTILink engine.
Root Cause
The logs configured by the CTILink Engine are not configured with complete details required and are configured in the incorrect location.
Resolution
Perform the following local-changes:
File Location:
- Open the CTILINK Engine rule form.
- Navigate to the Logging Tab.
- Modify the FileNamePattern value to represent the location where the log must be generated.
- Save the changes.
Logging Details:
- Navigate to Designer Studio > ChannelServices > PegaCall > Tools & Settings.
- Click Logging tab > Logging Settings. This is the generic PegaCTI log.
- Modify the FileNamePattern value to represent the location where the log must be generated.
- Save the changes.
Published October 12, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.