Support Article
Pega Pulse error "File doesn't exist" when uploading document
SA-9631
Summary
Error is displayed when you upload documents via Pega Pulse.
Error Messages
"** File <name> doesn't exist"
Steps to Reproduce
The Composite Portal harness contains a pxActivityStream section. Open the Portal and try to upload a file under Pulse section.
Root Cause
There are 2 causes of this issue.
1. When checking for the sanity of file name, a file is created under application server bin directory and then deleted. This causes issues when the file system is not writable as in case of most production systems.
2. When opening the Portal, the Pega Pulse section requires a ‘form’ tag on the HTML page. In this, the case developer was using a Screen layout in the harness, which does not create a form tag because screen layout does not perform a submit action.
Resolution
First issue is resolved by Hfix-21706.
Second issue is resolved by the following 2 options:
- Use Container layout instead of screen layout in your harness. This is recommended.
- Wrap the “pxActivityStream” section inside a “<form>” tag. This is not recommended and generates Warnings of “form” usage
Published June 12, 2015 - Updated October 8, 2020
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