Support Article

Pega Requirements functionality conflict with inflight work

SA-33372

Summary



After upgrading from PRPC 6.3 SP1 to 7.2.1 with Pega Requirements and the FSIF application inplace, requirement work objects generated are not sharing the linked relationship with the primary work object as was the case in the prior version of the FSIF application. The updated architecture institutes a cover and covered relationship for the primary work object and requirement work object, which for existing inflight requirement work objects cause them to not be operable.

Error Messages



Not Applicable

Steps to Reproduce

  1. Attempt to open any inflight work object from prior to the upgrade.


Root Cause



An issue in the custom application code or rules. Customer is upgrading from an aged release and native support is for an update from last release.

Resolution



Apply HFix-31046, which provides a mechanism to upgrade the previously created work objects.

Published February 7, 2017 - Updated February 11, 2017

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.