Support Article
Performance issue - sporadic spikes in response times
SA-2434
Summary
Users of the application are facing sporadic / intermittent spikes in response times
Error Messages
NA
Steps to Reproduce
NA
Root Cause
From analysis of the PegaRULES-ALERT log files from multiple days and multiple nodes from production the external webservices calls (Rule-Connect-SOAP) calls clearly indicate as the root cause of the performance bottleneck. Also the PegaRULES log files indicate issues arising out of SocketTimeoutException(s) on SOAP Webservices calls and the large numbers of TCP ports on “CLOSE_WAIT”
Resolution
The following recommendation have been provided to alleviate this issue –
- HFix-6894 - options to set apache http connection pool size for R-C-SOAP
- A list of identified external webservices whose response times / performance SLA needs to be optimized.
Pega DBAs recommend adding the following indexes to Pega ‘queue’ tables to optimize performance of SPPR_SYS_RESERVEQUEUEITEM_B in production.
create index queue_reserve on pr_sys_queues (pyMinimumDateTimeForProcessing ASC, pyItemStatus ASC);
create index queuesvc_reserve on pr_sys_queue_execreq_svc (pyMinimumDateTimeForProcessing ASC, pyItemStatus ASC);
create index queueconn_reserve on pr_sys_queue_execreq_conn (pyMinimumDateTimeForProcessing ASC, pyItemStatus ASC);
create index queuesla_update on pr_sys_queue_sla (pyItemId ASC, pyItemStatus ASC);
create index queuesla_reserve on pr_sys_queue_sla (pyMinimumDateTimeForProcessing ASC, pyItemStatus ASC);
Published January 31, 2016 - Updated October 8, 2020
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