Support Article
Poor Internet connectivity due to enrollments
SA-25667
Summary
User has observed that Network failures are reported in the log files on mobile or Ipad.
Error Messages
error|XXXXX.prweb.prwebldap2.xxxxx.xx.xx.standard|JS: Client Store synchronization failed with error 2: Error when sending request to the server: ClientStore HTTP request failed with: Network failure:A server with the specified hostname could not be found.
Steps to Reproduce
Not applicable.
Root Cause
A third-party product issue, for Andriod 6.0 If a user leaves a device unplugged and stationary for a period of time, with the screen off, the device enters Doze mode. In Doze mode, the system attempts to conserve battery by restricting apps' access to network and CPU-intensive services.
It also prevents apps from accessing the network and defers their jobs, syncs, and standard alarms.
For iOS reasoning behind this is more or less the same.
Resolution
The simplest solution for user is to increase auto-lock time, or set it to never. On iOS it is Settings>General>Auto-Lock.
HybridClient on iOS could start background task to complete synchronization (iOS system does not guarantee in 100% that it will be completed) or HybridClient on iOS could keep screen on for synchronization period, user still can move app to background, or lock it manually.
Published August 3, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.