Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

poor Parse XML performance

SA-12000

Summary



When the associate selects an account and end user spin off calls to another application to populate transaction data. User can see in the logs that the response time is usually sub second to a second. In the alert logs noticed that pxConnectInMapReqElapsed will be around 20 seconds causing the screen to display the spinning blocks for an extended period of time. This occurs when the associate is on the phone with the end user causing a negative experience. 

Error Messages



No error message

Steps to Reproduce

  1. The associate selects an account and end user and chooses to proceed with the claim. The screen then shows the spinning blocks for an extended period of time.

Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules.

Resolution



This issue is resolved through the following local change: 

Rule set: Pega-IntegrationEngine
Purpose: switchtooldassembler 
Value: false

This is default setting(false) if not set explicitly.
Suggest Edit

Published July 10, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us