Support Article
Program Run is failing
SA-33096
Summary
When we are trying to run flow, it's getting stuck at process flow and not moving further.
While tracing the same we found that it's moving to some "UnhandledInboundSMS " workbasket.
Error Messages
Not Applicable
Steps to Reproduce
- Launch Marketing poratal
- Run the program
Root Cause
A defect in Pegasystems’ code or rules:
Upon debugging we found that at Step 5 of activity AssociateCustomer, CustomerID is coming as blank.
When printed out step page (ResultsPage.pxResults(1)) in the logs. Below was the response.
<pagedata>
<pxObjClass>PegaMKT-Service-InboundSMS</pxObjClass>
<CUSTOMERID>12121212</CUSTOMERID>
</pagedata>
Where as SelectColumn value is CustomerID (please note its not in caps). When Java step (below is code in java step) is executed CustomerID value on parameter page is set to blank.
tools.putParamValue("CustomerID", tools.getStepPage().getString(tools.getParamValue("SelectColumn")));
SelectColumn is returning CustomerID instead of CAPS CUSTOMERID.
Resolution
Perform the following local-change:
Modify Step 3 (Property-Set) of the activity AssociateCustomer. Change the property (SQLParamPage.pxResults(<APPEND>).PropertyName) to the below.
"SELECT " + Param.SelectColumn + " AS \"" + @String.trim(Param.SelectColumn) + "\" FROM "
Here we have added 'AS' clause which was missing.
Published August 23, 2017 - Updated December 2, 2021
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