Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Property value set using an activity does not display

SA-53046

Summary



Setting a property value using an activity, does not display the value in subsequent actions.


Error Messages



Not Applicable.


Steps to Reproduce

  1. Create a section with a button
  2. In the actions of the button, add a Run Activity action to launch an activity that sets a property on a top level page
  3. Add a RunScript action that invokes a JavaScript function, passing the property value as a parameter
  4. Run the flow. The new property value does not display in the function


Root Cause



A defect in Pegasystems’ code or rules.


Resolution

Perform the following local-change:

Use a 'Refresh Section' action which invokes the activity instead of the 'Run Activity' action.

Alternatively, update the Pega application. This is fixed in the later Pega releases.

Suggest Edit

Published March 23, 2018 - Updated October 8, 2020

Did you find this content helpful? Yes No

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us