Support Article
PRPC717[DB]Deadlock occur when launching an Intent
SA-12765
Summary
When a CSR launches a CTI Call Interaction in the CPM Portal, it occasionally fails with a pyCommit Error displaying to the CSR.
Error Messages
2015-07-27 10:10:40,303 {ABSOLUTE} [ WebContainer : 6] [ntactCentre:02.01.01] (WithErrorHandling.Work_.Action) ERROR a_hopstname|aa.bb.ccc.ddd CSHDDW9 - Error in commit() com.pega.pegarules.pub.database.DatabaseException: Database-General Problem clearing out old indexes for instance XXXXX-OPS-CC-WORK S-2988305, purpose CAServiceItemsByNINumber 1205 40001 Transaction (Process ID 674) was deadlocked on lock | communication buffer resources with another process and has been chosen as the deadlock victim. Rerun the transaction. From: (H03901FB7E4CE18681AFAAA350C99E1B2:aa.bb.cc.ddd) SQL: delete from dbo.an_index_name where pxInsIndexedKey = ? and pxIndexPurpose = ?
Caused by SQL Problems. Problem #1, SQLState 40001, Error code 1205:
com.microsoft.sqlserver.jdbc.SQLServerException: Transaction (Process ID 674) was deadlocked on lock | communication buffer resources with another process and has been chosen as the deadlock victim. Rerun the transaction.
at com.pega.pegarules.data.internal.access.ExceptionInformation.createExceptionDueToDBFailure(ExceptionInformation.java:257)
at com.pega.pegarules.data.internal.access.Indexer.clearIndexesForPurpose(Indexer.java:1299)
at com.pega.pegarules.data.internal.access.Committer.performOps(Committer.java:155)
at com.pega.pegarules.data.internal.access.DatabaseImpl.attemptToProcessUpdates(DatabaseImpl.java:2625)
at com.pega.pegarules.data.internal.access.DatabaseImpl.processUpdates(DatabaseImpl.java:2288)
at com.pega.pegarules.data.internal.access.DatabaseImpl.commit(DatabaseImpl.java:2027) at
com.pegarules.generated.activity.ra_action_commitwitherrorhandling_6c6c3f21ead5ea2a97cdc30349237e37.step4_circum0(ra_action_commitwitherrorhandling_6c6c3f21ead5ea2a97cdc30349237e37.java:492)
at com.pegarules.generated.activity.ra_action_commitwitherrorhandling_6c6c3f21ead5ea2a97cdc30349237e37.perform(ra_action_commitwitherrorhandling_6c6c3f21ead5ea2a97cdc30349237e37.java:120)
Steps to Reproduce
1. Log in to CPM.
2. Create an ICALL- item.
3. Attempt to launch an Intent.
Root Cause
The cause of database deadlock and poor performance is because the database table associated to the database index is poorly fragmented.
Resolution
Follow the procedure as documented in the below PDN article to resolve the issue.
http://pdn.pega.com/node/285041
Published August 12, 2015 - Updated December 2, 2021
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