Support Article
Pulse messages are not posted to dashboard
SA-87886
Summary
The pxpostmessage is utilized to post messages (or notes) entered on a case, to Pulse and to display the messages on the dashboard. However, the messages do not display on the dashboard. The issue occurs intermittently.
Error Messages
Not Applicable
Steps to Reproduce
- Configure a field to capture notes on a case
- Use pxPostMessage to post a note with the value in the above field
- Configure the pyPostDetaiils section in the dashboard to display the pulse notes
Root Cause
The pyRetrieveActivityPosts report definition does not return the pulse post message entries which are posted from the work object upon approval or rejection (with pyVerb as post). For a few posts, pyUpdateDateTime and pycreatedatetime are same. A filter condition (.pxUpdateDateTime != .pxCreateDateTime) is present in pyRetrieveActivityPosts (condition G). Hence, the posts do not get retrieved.
Resolution
Perform the following local-change:
Remove the filter condition (condition G) in the pyRetrieveActivityPosts report definition.
Published December 2, 2021
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