Support Article
pyLASTRESERVEDID column is reset post application update
SA-55277
Summary
Installing Strategic Application resets the pyLASTRESERVEDID column of the PC_DATA_UNIQUEID table which results in duplicate Case ID Exception. This occurs post update to Pega 7.3.1.
Error Messages
Duplicate Case ID Exception.
Steps to Reproduce
- Update from Pega 7.2.2 to Pega 7.3.1
- Install Pega Foundation for Financial Services (PFFS) 7.31.8 and its sample
- Installed Pega Customer Relationship Management for Insurance (CRMI) 7.31-5 ,and its sample
- Install Pega Customer Relationship Management (CRM) and CRM sample 7.3-14
- Run the flow
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Here's the explanation of the reported behavior:
As part of the upgrade process, it is recommended not to install the samples of strategic applications.
Samples of Strategic Applications have instances of PC_DATA_UNIQUEID, which resets or modifies the PC_DATA_UNIQUEID table column, pyLASTRESERVEDID.
Published August 24, 2018 - Updated October 8, 2020
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