Support Article
pySLAGoal and pySLADeadLine values are setting null
SA-28077
Summary
The user has upgraded their application from 6.3 to 7.2.
In 7.2 version, pySLAGoal and pySLADeadLine values are setting null in step 5 of Resolve activity. So, those values are getting blank in the case id after resolution.
And, this is not there in 6.3 version.
Error Messages
Not Applicable
Steps to Reproduce
- Create any work case.
- Resolve the case.
- Check for Goal and Deadline values in the harness.
Root Cause
In Work-.Resolve Activity,Step-5 was added because there is no SLA event scheduled to take place anymore, since the work object has been resolved.
Resolution
Below is the Local Change:
- Do a save as of the ‘UpdateStatus’ activity into your own RuleSet and workpool, you can delete all the steps present in the newly saved activity.
- Add a step ‘property-set’ method , set the pySLAGoal and pySLADeadine values into local variables.
- Call ‘Work-.UpdateStatus’ activity, make sure that input parameters are passed properly.
- Add a step ‘property-set’ method , set the local variables values to pySLAGoal and pySLADeadine.
Published October 7, 2016 - Updated October 8, 2020
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