Support Article
pyStatusWork is overridden to Resolved-Unspecified
SA-74855
Summary
All the statuses (For example: Active, Retired, Resolved) are overriden to Resolved-Unspecified post upgrading to Pega 8.1. Initially, the status is changed to Resolved and later it is overridden to Resolved-Unspecified.
If the user does not provide status values, the current case is set to Resolved-Completed and open child cases are set to Resolved-Unspecified. This is mentioned in the Case Resolution of the help document. However, the current case is not a child case.
Error Messages
Not Applicable
Steps to Reproduce
- Upgrade Pega 7.4 to Pega 8.1.2
- Set the work status to Resolved in the end shape of the previous process
- Run the case. The status is set to Resolved initially and later it is overridden to Resolved-Unspecified
Root Cause
A defect in Pegasystems’ code or rules. The Workstatus configuration is different on Pega 8.1. If a stage is marked as resolution and the status is not provided, it is marked as Resolved-Unspecified in the resolution.
Resolution
Here’s the explanation for the reported behavior:
Design time validation is already present indicating that a status other than Resolved- cannot be provided. The changes are added to Sync at runtime and design time behavior on Pega 8.1.
Published August 19, 2019 - Updated December 2, 2021
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