Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

'pyUseCheckOut cannot be UnChecked' records checked out by users

SA-13224

Summary



An approval mechanism is applied on a delegated rule. If a specific line is changed in a decision tree, the rule was copied from PL_Prod ruleset into a dummy ruleset (CheckInCandidates) and the work is routed to a manager workbasket. When the manager approves the change, the system copies the changed version into our production ruleset PL_Prod. In the 01-01-02 version of this ruleset, an issue occurred and the system marked this rule as checkout by the user. On logging in as this user, neither this check-out cannot be deleted nor the rule can be checked-in.

A new version 01-01-03 was created and this rule was delegated in this ruleset version. This version does not need approval mechanism.

The requirement is to change this Use check out feature in the security tab of the ruleset. The requirement is to unselect the checkbox and delegate this decision table without an approval mechanism. On unselecting this Allow Checkout feature in the user profile and unselecting Use check out feature, the system throws an exception.
 

Error Messages



Used to determine if Checkout/in applies to this ruleset.:pyUseCheckOut cannot be UnChecked: There are records checked out by users belonging to this RuleSetName


Steps to Reproduce



Save the ruleset version after unselecting the Use check out feature checkbox.


Root Cause



When you create and begin using a higher RuleSet Version but a locked, lower-numbered version still has one or more rules checked-out, those rules remain checked-out in the new, higher version.

No one can check these locked rules, because their version is secured. Also, developers will not be able to check them out when necessary (as they are already marked as checked out). They remain locked indefinitely each time you create a new RuleSet version.

Even if you log in as the Operator ID who holds the lock, unlock the lower RuleSet version, and delete the checked-out rules, the higher RuleSet version does not reflect this change and the rules remains checked out.

Resolution



The below PDN article explains the procedure to cancel rule check-out status with an activity.

http://pdn.pega.com/node/1072

Published August 26, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us