Support Article
Queue execution mode does not work with Connect-REST
SA-74375
Summary
When the Connect is configured to use the Queuing mode, invoking a Connect-REST from a datapage creates and associates a Request Processor. The System-Queue-ExecutionRequest-Connect-Default is the Queue class, which is mapped to the pr_sys_queue_excreq_conn table. When the data page is run, the queue item is missing from the table.
Error Messages
Not Applicable
Steps to Reproduce
- Run the Connector wizard and allow it to create the necessary rules.
- Set the connector as a Queue mode.
- Modify the Processing options to 'Intended for queuing'.
- Create and update a Request Processor in this Connector rule.
- Ensure that the ProcessConnectQueue is running.
- Run a test activity to call the connector. The table does not have any entry.
Root Cause
An issue in the custom application code or rules
Resolution
Perform the following local-change:
Add a Commit operation in the activity to persist the queue item.
Published May 14, 2019 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.