Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

On Refreshing ListView the custom filter criteria is lost

SA-3928

Summary





After users selects a custom filter criteria in a listview and then refreshes the section using the provided refresh button the filter criteria is lost. The expected behaviour should be that the custom filter criteria is retained even after refresh.



Steps to Reproduce





The issue here is as follows:



1. In a given list view, the user selects some filter criteria.

2. Then the user clicks the refresh button.

3. After the user clicks the refresh button the data in the list view is refreshed. But the selected filter criteria is also lost. The user has to select the filter criteria again and this is not desired by the user. He/she wants the list view to be refreshed keeping the filter criteria intact.




Root Cause





The root cause of this problem is software use/operation error.  This behaviour is an expected behaviour.




Resolution





The explanation for this behaviour is as follows: T
his is an expected behaviour. Because refreshing the section means loading the fresh data of the section. Hence applied filter criteria on the listview will be lost and list view with no filter criteria will be loaded.
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us