Support Article
Remote case is not opening in Case Worker (pyFCMRCaseListGrid7)
SA-33551
Summary
Federated Case Management (FCM) 7.1.2 with Pega 7.2.1 and being tested for the first time.
The federated worklist should be added to the end user portal like other worklists are. Remote cases are not opening when when clicking on a case in a list of remote cases (in pyFCMRFederatedCaseList7 section) via Case Worker .
Both pyFCMRFederatedCaseList7 and pyFCMRFederatedWorkList7 work fine.
Cases and assignments are opening but only using Case Manager Portal.
In Case Worker portal the same harnesses with the same navigation links configuration does not work.
No remote assignments, no remote cases are opening, although, activity pyPopulateParams is called in both cases.
Error Messages
Not Applicable
Steps to Reproduce
1. Configure PRPC to use with FCM technology.
2. Configure remote case list with using section pyFCMRFederatedCaseList7.
3. When list of remote cases is shown, click on anything, observe nothing happens.
Root Cause
By default, the Case Worker is using a single document portal.
This makes it inappropriate to show remote work item as remote work item needs be opened in a separate Iframe, which means it requires its own tab.
Resolution
Perform the following local-change:
If user configures the Case Worker to support multiple document, then it works fine.
This can be done by doing the following:
- Save pyWorkerPortalContent section in the ruleset.
- In the pyWorkerPortalContent section, remove the Dynamic container.
- Add a new dynamic container and make sure to select “Multi Document” (this can’t be changed later on):

4. In this new dynamic container, reference section “pyCMMyWorklist” (same section as originally referenced).
Published February 21, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.