Support Article
Report Editor stops responding for large data sets
SA-69182
Summary
When using the Report Browser or the Report Editor for classes with multiple rows (millions), the editor stops responding and a blank page displays.
Error Messages
Not Applicable
Steps to Reproduce
Use the report editor in the report browser to create a report on a class with multiple many rows (millions) in its database table.
Root Cause
A defect in Pegasystems’ code or rules:
The issue is caused by the query to the database to obtain the number of results in the result set for the report, when paging is enabled. The count is obtained to accurately present the paging gadget.
The database query to obtain the count is slow on any database. This is because it involves assembling the result set for the query and then scanning the table of the result set to count the results.
This condition can be identified by running the report with and without paging enabled. If this issue exists, the Package results step in the Tracer displays a much larger elapsed time.
Below are screenshots of the same query that is run with and without paging.
With paging enabled on the report defintion:

Without paging:

Resolution
Apply the below hotfixes.
- HFix-44305
- HFix-44623
Published January 20, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.