Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Report filters are not cleaned.

SA-20763

Summary



In a report definition rule custom filter is enabled. 
The report is run and a value is applied on the customer filter section. When the report is run again from the same user session, it still holds the filter values from the previous run.


Error Messages



Not Applicable

Steps to Reproduce



1. Configure a Report Definition.

2. Configure a custom Filter that requires a custom section.

3. Run the report.

4. Apply a filter value.

5. Close the report.

6. Run the report again from the same user session. The old filter values from previous run will still be seen.


Root Cause



When a custom Filter is configured it creates a new clipboard page. That clipboard page holds the value of the filter value applied. 
Thus when the report is run again from the same user session the custom filter section populates the value fro9m this page and shows the old one.

Resolution



The OOTB clear filter button that automatically comes on the custom section has to be used to clear the values everytime.
Suggest Edit

Published March 16, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us