Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Results not displayed when filtering by workbasket

SA-33707

Summary



When using “Assigned to Workbasket’ as filter in bulk processing the results are not displayed.


Error Messages



Not Applicable


Steps to Reproduce

  1. Launch Bulk Actions screen and select ‘Process’.
  2. A new screen will be displayed with filter options.
  3. Select ‘Case Type’ as “is Any” and in the next filter select “Assigned to Workbasket’ and in filter value provide a valid workbasket name in the filter value and click on the ‘Filter Cases’ button, all the cases assigned to that workbasket will be displayed.
  4. Now delete the workbasket name in the filter value column and hit the ‘Filter Cases’ button, no results are displayed.


Root Cause



A defect in Pegasystems’ code or rules.

Resolution



Perform the following local-change:
  1. Save the Embed-FCondition.pzGetAssignedToBasketList activity as GetAssignedToBasketList in application rulest and comment out the step 4.
  2. ​Change the AutoComplete control ( in the layout 3) used in the "pyDisplayPropertyTypeInBulkProcessSpl" section to new pxAutoComplete control. Use the Same configuration as the deprecated AutoComplete control to populate the results, and refer the new activity "GetAssignedToBasketList" in the run activity.

Published February 21, 2017 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us