Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Rule resolution error displays on the UI

SA-68989

Summary



Rule resolution error displays on the User Interface (UI) though the rule is available in the system.


Error Messages



Rule resolution error


Steps to Reproduce

  1. Create a rule in a ruleset.
  2. Do not include the rule set in the operator’s application stack and in the application rulesets.
  3. Refer that rule from a section.
  4. Load the section.


Root Cause



An issue in the custom application code or rules.
The ruleset in which the rule was available was not present in the operator’s ruleset stack.



Resolution



Perform the following local-change:

Add the ruleset which has the rule, to the application ruleset.
 

Published January 5, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us