Support Article
SAML Authentication set up does not work
SA-82344
Summary
On setting up and mapping the SAMLAuth Service, and invoking the service from OKTA, unable to log in to the system.
Error Messages
There has been an issue please contact your system administrator
Steps to Reproduce
Invoke the Single Sign-On (SSO) URL. The system generates an error and does not authenticate despite the OKTA authentication being successful.
Root Cause
An issue in the custom application code or rules.
There was a mapping with the NameID in the SAML profile which was not specified in the OKTA profile.
Resolution
Perform the following local-change:
Remove the mapping NameID in the SAML profile (since no such Attribute is defined at the OKTA end).
Published August 15, 2019 - Updated December 2, 2021
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