Support Article
SAML timeout activity is not being triggered
SA-7488
Summary
SAML timeout activity is not being triggered
We have specified a Timeout activity of pySAMLWebSSOTimeoutActivity but it never gets called.
Error Messages
SAML timeout activity is not being triggered
Steps to Reproduce
Configure SAML authentication.
Define a timeout activity: OTB pySAMLWebSSOTimeoutActivity
Set AccessGroup Timeout
Login via SAML enable SSO servlet.
Wait for timeout interval.
Timeout activity will not get called.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules.
We are aware of this issue in PRPC 7.1.X. This will be fixed in PRPC 7.1.8.
The core Data-Admin-AuthService rule has a setting “Use PRPC Timeout”. When this is enabled and the AccessGroup timeout is reached then the
timeout activity defined is run. The problem is that the Data-Admin-AuthService rules that are SAML enabled have no visible setting
for the “Use PegaRULES timeout” setting and by default it is not enabled.
Resolution
This issue is resolved through the following local change.
There is a simple work around for this issue. Create an run the following actiivty as shown below. This will set the pySupportPegaTimeout property to true.
Activity Class / Name:
Pages and Classes:
Step 1: Open instance
Instance Handle is pzInskey of the Data-Admin-AuthService to modify.
Step 2: Set pySupportPegaTimeout to true
Step 3: Obj-Save
Published January 31, 2016 - Updated October 8, 2020
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