Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Scheduled process show incorrectly in SMA

SA-6423

Summary



User has observed 308162 scheduled processes in System Management Application (SMA) and the count was increasing by 2000 in every 10 minutes. In the database table - PR_SYS_QUEUE, user could see around 80000 records in scheduled status.

ERROR MESSAGES

Not Applicable

STEPS TO REPRODUCE

a) Open SMA -> under Agent Management -> System Queue Management : Beside Scheduled' status, check the Item Count.
b) Verify the count under table PR_SYS_QUEUES. This count mismatch with SMA.

ROOT CAUSE

SystemIndexer and SystemWorkIndexer agents were not running. Due to this reason, large number of records were observed in the PR_SYS_QUEUES table.

RESOLUTION

Suggested user to start SystemIndexer and SystemWorkIndexer agents. These agents create indexes for Rules and Work-Items. These agents also help event processing. System event evaluation agent uses the items queued by SystemWorkIndexer. Stopping this agent results in accumulating Queue items, performance will be affected due to large volume of queue items, Search and Events does not work.

Following steps were shared with user before starting the agents:
  1. Stop all activity on this system (all nodes connected to the database)
  2. Truncate the PR_SYS_WORKINDEXER_QUEUE table.
  3. Start re-indexing manually - Re-index Work index from the Search landing page.
                 Pega Button->System->Settings->Search.
     d. Start the SystemIndexer and SystemWorkIndexer agents.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us