Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Search does not work correctly



Search does not work correctly. The search works for sometime after restarting the Search node.

Error Messages

[PegaRULES-Batch-36] [STANDARD] [ ] [PegaRULES:07.10] ( ERROR - Incremental indexing of 'WORK' entries failed: Indexing request failed. Please contact your system administrator. Indexing request failed. Please contact your system administrator. 
at com.pega.pegarules.session.internal.mgmt.Executable.runIncrementalIndexer( 
at com.pegarules.generated.activity.ra_action_pzftsincrementalindexer_f5d34531e6ce3428b7cfcf71c389b182.step2_circum0( 
at com.pegarules.generated.activity.ra_action_pzftsincrementalindexer_f5d34531e6ce3428b7cfcf71c389b182.perform( 
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(

Steps to Reproduce

Restart the Search node.

Root Cause

An issue in the custom application code or rules.

FTSException occurs due to either of the following reasons. Enabling Debug loggers on '' provides the reasons that caused the issue.
  1. Insufficient index nodes for the ElasticSearch quorum to be met, which is required for successful indexing. This is ensured by performing the below steps,

    a. When an Index or a Search node is stopped for maintenance, ensure that it is shutdown gracefully such that the replica count of the index is updated correctly.

    b. If Step A is not followed correctly, the above exception is generated in logs.
    To address this, check for offline index nodes, that is, Pega nodes which are no longer running, but have a Search Index directory set from the Search landing page. If there are any offline index nodes, remove them from the Search landing page and restart the Pega node.

  2. Insufficient disk space to store the indexes - Ensure to increase the volume that stores the ElasticSearch indexes before the volume fills up to 85% or above (as a best practice).
  3. When search index directory location is shared between multiple Pega nodes of different deployments. This occurs when the Product rule with System-Status-Nodes instances of one environment is imported to another environment.


Perform the following local-change:
  1. Ensure that the following Dynamic System Settings (DSS) instances are set to TRUE:

       a. Indexing/distributed/enabled
       b. Indexing/distributed/Index_enabled
       c. Indexing/distributed/Search_enabled

  2. Clear all the existing index files from the new indexing directory (if they exist).
  3. Run the pzResolveFTSIndexEntry for each node ID.
  4. Restart the Tomcat server to force the settings to take effect

Published August 19, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us