Support Article
Searching by tag for tagged KM articles doesn't work
SA-79050
Summary
A Knowledge Management (KM) article is published with a tag(s). On searching for one of the tag values, non-tagged content with related terms displays at the top of the search results instead of the article with the specific tag.
Error Messages
Not Applicable
Steps to Reproduce
- Create an article with a specific tag.
- Search by that tag.
Root Cause
Pega KM 8.1 does not support the search of tags.
Resolution
Here’s the explanation for the reported behavior:
When using tags to search for the KM articles, the exact tag name must be used. If the tag name is specified incorrectly, the KM articles search will not return the correct articles.
Published August 15, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.