Support Article
Send Correspondence Intent Task does not send emails
SA-56622
Summary
When using the Send Correspondence intent task and CASendCorrespondence flow, emails are not sent intermittently.
Error Messages
Failed to find a 'Rule-Obj-Model' with the name CPMSETWORKPARTYDETAILS that applies to PegaCA-Work-Correspondence. There were 1 rules with this name... for example 'PegaCA-Party-OtherParty'
Steps to Reproduce
- In the Customer Service application, add Send Correspondence as an intent task.
- Send an email.
- Run the CPMCreateRecipientParties directly.
Root Cause
An issue in the custom application code or rules.
The CPMSendCorrespondence flow action was modified and did not include the CPMCreateRicipientParties post-processing activity.
The flow action intermittently used the CPMCreateRecipientParties post-processing activity.
When CPMCreateRecipientParties was run in isolation, it failed to locate the CPMSETWORKPARTYDETAILS data transform on the PegaCA-Party-OtherParty class.
Resolution
Perform the following local-change:
Set the post-processing activity in the CPMSendCorrespondence flow action as below:
- Set Run activity to CPMCreateRecipientParties.
- Set the EmailSendTo parameter to .ToRecipients.
- Set the EmailSendCC parameter to .CCRecipients.

Published September 6, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.