Support Article
Service REST rule updates are not saved
SA-8809
Summary
There are two issues that limit the effective configuration of Service REST rule in Pega 7.1.7.
- On the Request tabs of both POST and PUT sections on the Service REST rule, the "Map To" smartprompt lists has the incorrect options.
- The value entered in "Map to Key" value of Message Data on Request Tab of POST and PUT method on Service-REST rule is not persisted when the updated rule is saved and then re-opened.
Error Messages
Not Applicable
Steps to Reproduce
- Create a new Service REST instance
- Review the "Map To" smartprompt list on the Request tab for PUT or POST Methods and cross check it against the help file and/or previous Pega versions. The list for Request seems to be the one for Response when it should be different. Include the option for Parse XML in request for example.
- On the POST or PUT Request tab,
- Enter a "Map to" as 'Clipboard' under Message data section
- Enter a property reference value in "Map to Key" value
- Save the rule
- Close Rule
- Open Rule
Expected Result: Rule gets saved and is re-opened with the mapping options entered.
Actual Result: Map to key value gets cleared and the entered values are not persisted.
Root Cause
The root cause of this problem is a backwards compatibility defect in Pegasystems’ code/rules.
Resolution
These issues are resolved by HFix-21532 in Pega 7.1.7. This does not occur in earlier Pega versions and will be resolved in Pega 7.1.8.
Published January 31, 2016 - Updated October 8, 2020
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