Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Siteminder protected URLs not working



After upgrade from PRPC 6.2 to Pega 7.1.8, users not able to access the application which are protected with site minder.

Error Messages

No error messages, but site minder protected URLs are not working.

Steps to Reproduce

1. Upgrade and deploy all Pega 7 products.
2. Deploye Pega 7.1.8 EAR file in production environment and regenerated the plugin.
3. Execute App scan changes in Webserver.
4. Restart both webserver and app server.
5. Observe that the Siteminder protected URLs are not working.
6. Rever the app scan changes. Still Siteminder protected URLs are not working.

1. When context root is not specified it should load index.html – This is not happening and it throws file not found error.
2. When site minder protected URL is specified it should redirect to login.fcc – Redirection of login.fcc is shown in address bar but it throws file not found error.

Root Cause

A defect or configuration issue in the operating environment, 
  • The network was configured to only allow traffic with “HTTP” protocol earlier, thus blocking the “HTTPS” requests. User was trying to access through secure channel.


Perform the following local-change:

Disable secure port settings in WebSphere server resolves the issue.


Published May 23, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us