Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

SLA agent not able to resume work objects sometimes

SA-89056

Summary



The SLA agent is unable to resume a few work objects from a workbasket.

For example, 

If 3000 work objects are present in a workbasket in the course of an entire day, the SLA agent does not resume about 100-200 work objects.

While submitting the work objects manually from the assignment, they resume correctly.



Error Messages



Not Applicable


Steps to Reproduce



Configure an SLA agent to resume work objects.


Root Cause



An issue in the custom application code or rules.

The SLA agent is not designed for high volume real-time processing. One SLA thread is available per node. Nodes must be added to scale with the SLAs.


Resolution


Perform the following local-change:

Write a custom agent to add the nodes.

For a 'higher speed batch', create custom agents each of which execute the same processing activity.

In the custom agent, resume flow processing.

Published October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us