Support Article
SLA Commit does not occur when ResumeFlow is invoked in activity
SA-87567
Summary
The OverallSLA contains an activity that is invoked when the Deadline is reached. This activity invoked the ResumeFlow with the following parameters:
- flowAction
- flowName
- calledFromServiceLevel
Error Messages
Not Applicable
Steps to Reproduce
- Create a FlowAction with an SLA - WaitingForSellerResponse flow action.
- Include an OverallSLA for the work object.
- Retain the work object in the WaitingForSellerResponse flow action.
- Create an activity (testactivity) to invoke the ResumeFlow for the above flow and action.
- Invoke the testactivity when the deadline reaches the OverallSLA.
Root Cause
An issue in the custom application code or rules.
The obj-Save was performed at the custom activity which overrode the SLA data. Hence, the commit was not performed.
Resolution
Perform the following local-change:
Remove the Save operation in the activity. The agent will manage the Saves and Commits.
If the Save operation is required, handle the commits explicitly.
Published October 8, 2020
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