Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

SLA issue with 'only calculate using business days' selected

SA-49773

Summary



The Goal (pySLAGoal) and Deadline (pySLADeadline) time are not calculated as expected when “Only calculate using business days” is enabled.

For example, if case is created before stating of the business hour, and goal time is 6 hours and deadline time is 12 hours, pySLAGoal is showing 190000.000 and deadline time is showing 160000.000 (next day) for every case.

Error Messages



Not Applicable


Steps to Reproduce

  1. Create Flow Rule.
  2. Create SLA Rule and set "pySLAName" property in initial data transform.
  3. Create Calendar and associate to operator.
  4. Create the WorkObject and verify the Goal/Deadline time.

Root Cause



Behavior is as expected.

Resolution



Here’s the explanation for the reported behavior:

As per the business day and hours defined in the calendar, if the goal / deadline time passes the business hour of current date, then the goal / deadline time will be assigned the respective value of the next day.

Also check the time difference of current time zone with GMT to calculate the time as goal / deadline time are shown in GMT in the clipboard.

Published April 12, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us