Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

SLA is not triggered for transferred assignments

SA-17696

Summary



SLA is not triggered for assignments after transferring them from worklist to workbasket or vice versa, using the drag and drop approach in Case Manager portal.

Error Messages



Not Applicable


Steps to Reproduce



Transfer an assignment (with an associated SLA) from worklist to workbasket or vice versa.
 

Root Cause



A defect in Pegasystems’ code or rules. On transferring the assignment from workbasket to worklist, the assignment is transferred but the queue item associated with the workbasket assignment is not re-queued with the new assignment details. Therefore, the SLA events are not fired after the transfer. This occurs because the Reassign activity (called during the assignment transfer) expects a parameter UpdateSLA to be true to re-queue the queue item, but this parameter was not passed during drag and drop and hence the queue item was never updated.

Resolution



Perform the following local-change: 

1. SaveAs pyCMWorkDraggable control in custom ruleset
2. Add the parameter in  the below code snippet (transferUrl.put ("UpdateSLA", true)) to the pyCMWorkDraggable control



3. Save the pyCMWorkDraggable control
4. Apply HFix-25313

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us