Support Article
SMS Account Setup is not working
SA-66169
Summary
Pega Marketing 7.22 is installed on Pega 7.3.
A new Outbound SMS account is configured. ConnectionException displays when performing a Test Connection.
Error Messages
Exception caught connecting to SMS server; ie.ncl.msg.ConnectionException: Cannot connect - Invalid password OR bind failed because bind limit has been exceeded Disconnected successfully from SMS server.
There is a mismatch on the bind type. Current SMS server is setup in transceiver bind type where as Pega is expecting transmitter bind type.
Steps to Reproduce
- Navigate to the SMS Configuration landing page.
- Enter the SMS connection details.
- Click Test Connection.
Root Cause
A defect in Pegasystems’ code or rules.
On debugging, it is observed that the application sent an Short Message Peer-to-Peer (SMPP) value for the system_type property whereas the SMSC service provider expected the value to be 1.
The mmstest.type value is hardcoded in the TestSMSConnection function.
Below is the line of code where the mmstest.type value is hardcoded to SMPP.
......
properties.setProperty("mmstest.port", smsPort);
properties.setProperty("mmstest.type", "SMPP");
properties.setProperty("mmstest.bindType", bindType);
......
Resolution
Perform either of the following local-changes:
- While setting the Outbound SMS connection, in the Additional Settings tab, set the property name as 'type' only and value as 1.
With this setting, only the Test Connection functionality will fail; however, the rest of the Outbound SMS functionality works.
- Create a new function similar to the TestSMSConnection function and change the line of code where the mmstest.type value is set to SMPP and value to 1.
- Request the SMSC service provider to change the system_type value to SMPP.
Published December 13, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.